VMB Sevensegment Device Specification

Sevensegment Device Specification

The Sevensegment device offers just eight byte of memory. Each byte corespondes to one digit in the display, the most significant byte to the leftmost digit the least significant byte to the right most digit. Esch bit in each byte corresponds to one of the seven segments plus the decimal dot to the right of the digit. Setting the bit to 1 will turn the corresponding bit on, setting the bit to 0 turns the corresponding bit off.

The correspondnec of bits to segments is as follows:

Bit | 0x01 | 0x20 | 0x40 | 0x80 | 0x10 | 0x20 | 0x40 | 0x80
Segment | Top Horizontal | Middle Horizontal | Bottom Horizontal | Left Top | Left Bottom | Right Top | Right Bottom | Decimal Point

Hence the Value 0x0102040810204080 results in the following display:

Sevensegment Configuration

The Sevensegement has the following configurable parameters:

host | localhost | the host where the bus is located
port | 9002 | the port where the bus is located
address | default | address where the resource is located
x | 0 | the x position of the window
y | 0 | the y position of the window
minimized | false | start with a minimized window
debug | false | to generate debug output
debugmask | 0xFFF0 | set mask to hide debug output
verbose | false | make debugging verbose, sets debug mask to zero
define | not set | to define a name for conditionals
config | not set | filename for a configuration file
help | false | to print information
These can be set in default.vmb