VMB Screen Device Specification

Screen Device Specification

Memory Layout

Byte | Mode | Name | Description
00 | R | X | error indicator
01-02 | R | - | zero
03 | R | Y | character count
04-06 | R | - | zero
07 | RW | Z | character

Operation

The program will contact the motherboard at [host:]port and register itself with the given address and interrupt. Then, the program will be ready to receive bytes and display them. Under Unix a Byte is displayed by sending it to the standard output. Whenever ready to receive a byte, it will signal an interrupt with the given interrupt number. At the given address it will provide a read/write octabyte in the format: given above.

The X byte signals errors. It will be 0x80 if an error occured and 0x00 otherwise. By setting the sign bit errors can be easily checked..

The Y byte contains the number of characters that were written to this address since the last output. This should be 0 if the address is ready to receive a character or 1 if the hardware is bussy with writing a byte. Any other value will indicate that characters were lost since the last write operation.

The Z byte contains the last character received. It is valid only if YY is not zero.

The complete ocatbyte will be reset to zero after a byte is output..

Configuration

The Screen has the following configurable parameters:
host | localhost | the host where the bus is located
port | 9002 | the port where the bus is located
address | default | address where the resource is located
interrupt | not set | interrupt sent when ready
x | 0 | the x position of the window
y | 0 | the y position of the window
minimized | false | start with a minimized window
debug | false | to generate debug output
debugmask | 0xFFF0 | set mask to hide debug output
verbose | false | make debugging verbose, sets debug mask to zero
define | not set | to define a name for conditionals
config | not set | filename for a configuration file
help | false | to print information

These can be set in default.vmb