VMB ROM Device Specification

ROM Device Specification

The ROM device offers a variable amount of read only memory at a configurable address. The content of the memory is taken form an image file. Any type of file can be used as an image file, as the file is just placed into memory and mapped into the address space. The maximum file size is 4GByte. The actual size depends on the size of the image file. The size of the image file is rounded up to multiples of 1 kByte. Upon Power On or Reset, the ROM image file is reread to update the ROM in case of changes were made to the image file.

ROM Configuration

The ROM has the following configurable parameters:
host | localhost | the host where the bus is located
port | 9002 | the port where the bus is located
address | 0x8000000000000000 | address where the resource is located
file |  | the file containing the ROM image
x | 0 | the x position of the window
y | 0 | the y position of the window
minimized | false | start with a minimized window
debug | false | to generate debug output
debugmask | 0xFFF0 | set mask to hide debug output
verbose | false | make debugging verbose, sets debug mask to zero
define | not set | to define a name for conditionals
config | not set | filename for a configuration file
help | false | to print information
These can be set in default.vmb