VMB RAM Device Specification

RAM Device Specification

The RAM device offers a variable amount (configure size from 1 up to 4GByte) of read/write memory at a configurable address. Upon Power On or Reset, the whole memory is set to zero.

RAM Configuration

The RAM has the following configurable parameters:
host | localhost | the host where the bus is located
port | 9002 | the port where the bus is located
address | 0x8000000000000000 | address where the resource is located
size | 1 | the number of bytes in the RAM up to 4GByte
x | 0 | the x position of the window
y | 0 | the y position of the window
minimized | false | start with a minimized window
debug | false | to generate debug output
debugmask | 0xFFF0 | set mask to hide debug output
verbose | false | make debugging verbose, sets debug mask to zero
define | not set | to define a name for conditionals
config | not set | filename for a configuration file
help | false | to print information
These can be set in default.vmb