VMB FLASH Device Specification

FLASH Device Specification

The FLASH device offers a variable amount of read7write memory at a configurable address. The content of the memory is taken form an image file. Any type of file can be used as an image file, as the file is just placed into memory and mapped into the address space. The maximum file size is 4GByte. The actual size depends on the size of the image file and the value of the size parameter. The size of the image file is rounded up to multiples of 1 kByte. If the size of the image file is less then the size specified, or if the file specified does not exist, the image is extended with zeros to give a flash memory of the size specified.

Upon Power Off or Reset, the memory content is written back to the image file. Upon Power On or Reset, the FLASH image file is reread to update the FLASH in case of changes were made to the image file. Through the use of the image file, the flash device provides persistent memory.

FLASH Configuration

The FLASH has the following configurable parameters:
host | localhost | the host where the bus is located
port | 9002 | the port where the bus is located
address | 0x8000000000000000 | address where the resource is located
file |  | the file containing the FLASH image
size | 1 | the minimum size of the FLASH memory
x | 0 | the x position of the window
y | 0 | the y position of the window
minimized | false | start with a minimized window
debug | false | to generate debug output
debugmask | 0xFFF0 | set mask to hide debug output
verbose | false | make debugging verbose, sets debug mask to zero
define | not set | to define a name for conditionals
config | not set | filename for a configuration file
help | false | to print information
These can be set in default.vmb